Se han descubierto varias vulnerabilidades en productos Cisco, siendo una de ellas de severidad crítica.

Recursos afectados:

  1. Cisco CVR100W Wireless-N VPN Router con versión anterior a Firmware Release 1.0.1.22.
  2. Routers Cisco IOS XR  con versión 6.1.1 de Cisco IOS XR Software cuando el servicio gRPC está habilitado en el dispositivo. El servicio gRPC no está habilitado por defecto.
  3. Cisco Aironet 1800 Series Access Points, versión 8.3.102.0, ejecutando Lightweight AP Software o una imagen Mobility Express.
  4. Cisco Aironet 2800 Series Access Points, versión 8.3.102.0, ejecutando Lightweight AP Software o una imagen Mobility Express.
  5. Cisco Aironet 3800 Series Access Points, versión 8.3.102.0, ejecutando Lightweight AP Software o una imagen Mobility Express.
  6. Porductos Cisco TelePresence pcon las versiones CE8.1.1, CE8.2.0, CE8.2.1, CE8.2.2, CE 8.3.0, or CE8.3.1:
    1. Spark Room OS.
    2. TelePresence MX Series.
    3. TelePresence SX Quick Set Series.
    4. TelePresence SX Series.

Recomendación

Detalle e impacto de las vulenarabilidades:

Las vulnerabilidades identificadas se detallan a continuación:

  1. Vulnerabilidad critica de búfer overflow en Cisco CVR100W Wireless-N VPN Router Universal Plug-and-Play, provocada por la comprobación incompleta de los datos de entrada UPnP. Podría ser aprovechada por un atacante adyacente de Capa-2 para ejecutar código  arbitrario o provocar una condición de denegación de servicio.
  2. Vulnerabilidad de denegación de servicio en Cisco IOS XR Software, provocada por el tratamiento inadecuado de las peticiones gRPC. El fallo podría permitir a un atacante provocar una condición de denegación de servicio al enviar peticiones especialmente diseñadas para aprovechar el fallo.
  3. Vulnerabilidad de denegación de servicio en Cisco TelePresence ICMP, provocada por la validación incorrecta del tamaño de los paquetes ICMP recibidos. El fallo podría permitir a un atacante provocar una condición de denegación de servicio al enviar peticiones ICMP especialmente manipuladas.
  4. Ejecución de código arbitrario en Cisco Aironet 1800, 2800, and 3800 Series Access Points Plug-and-Play provocada por la validación insuficiente de respuestas de los servidores PnP.

Más información

Fuente: Hispasec

Anuncios