Se ha confirmado una vulnerabilidad en Fortinet FortiMail que podría permitir a un atacante remoto sin autenticar construir ataques de cross-site scripting.

FortiMail es una solución de gateway de correo que proporciona una respuesta unificada a ataques entrantes. Se ofrece como hardware, dispositivo virtual o servicio basado en la nube. Entre sus características se incluyen antispam, antiphishing, anti-malware, sandboxing, prevención de fuga de datos, cifrado basado en identidades y archivo de mensajes.

La vulnerabilidad fue reportada por Ebrahim Hegazy

Got #CVE-2017-3125 for my latest #FortiMail #0day that allows Email Takeover. pic.twitter.com/C1RZW8R2xK

— Ebrahim Hegazy (@Zigoo0) 23 de enero de 2017

Recursos afectados

  • Se ven afectadas las versiones FortiMail 5.0.0 a 5.2.9 y 5.3.0 a 5.3.8. Fortinet ha publicado la versión FortiMail 5.3.9 destinada a corregir la vulnerabilidad.

Detalle de la vulnerabilidad

  • Como es habitual en este tipo de ataques el problema (con CVE-2017-3125) reside en un filtrado inadecuado de los datos antes de ser devueltos al usuario. Lo que podría facilitar a un atacante remoto crear una URL, que al ser cargada por el usuario permita la ejecución de código script en el contexto de seguridad del navegador de la víctima autenticada en FortiMail.
  • Al igual que todo este tipo de ataques podría permitir acceder a las cookies (incluyendo las de autenticación) y a información recientemente enviada, además de poder realizar acciones en el sitio haciéndose pasar por la víctima.

Más información:

Fuente: Hispasec

Anuncios