Wireshark Foundation ha publicado las versiones 2.0.12 y 2.2.6 que incluyen la corrección de 10 vulnerabilidades que podrían provocar condiciones de denegación de servicio.

Wireshark es una popular aplicación de auditoría orientada al análisis de tráfico en redes, que soporta una gran cantidad de protocolos y es de fácil manejo. Además Wireshark se encuentra bajo licencia GPL y disponible para la mayoría de sistemas operativos Unix y compatibles, así como Microsoft Windows.

Detalle de la actualización

  • En esta ocasión la fundación Wireshark ha publicado diez boletines de seguridad (del wnpa-sec-2017-12 al wnpa-sec-2017-21) todos ellos afectan a todas las versiones de las ramas 2.2 y 2.0.
  • Como es habitual, las vulnerabilidades corregidas residen en denegaciones de servicio por fallos en la implementación de disectores, que son los módulos responsables de analizar los paquetes de cada uno de los protocolos. La lista de los disectores y protocolos afectados incluyen IMAP (CVE-2017-7703), WBMXL (CVE-2017-7702), RPCoRDMA (CVE-2017-7705), BGP (CVE-2017-7701), DOF (CVE-2017-7704), PacketBB, SLSK, SIGCOMP y WSP. También se ha solucionado un bucle infinito en el analizador de archivos NetScaler (CVE-2017-7700).
  • De igual forma se han solucionado múltiples problemas no relacionados directamente con vulnerabilidades de seguridad y actualizado el soporte de diferentes protocolos.

Recomendación

Más información:

Fuente: Hispasec

Anuncios