Investigadores independientes han identificado una vulnerabilidad de desbordamiento de búfer en el software de MatrikonOPC’s SCADA DNP3 OPC Server, catalogada con importancia alta.

 Esta vulnerabilidad se produce cuando el servidor (estación maestra) se conecta a un dispositivo (estación) y ese dispositivo devuelve un paquete DNP3 con formato incorrecto.

Recursos afectados

MatrikonOPC SCADA DNP3 OPC Server version 1.2.0 y superiores

Impacto de la vulnerabilidad
  • Las versiones afectadas de MatrikonOPC contienen una vulnerabilidad específica que pueden hacer que el servidor se cierre y provocar que las comunicaciones con los dispositivos se detengan.
  • Un atacante remoto podría aprovechar esta vulnerabilidad para elaborar un exploit y provocar el corte de la conectividad DNP3 con múltiples dispositivos compatibles, como las RTU, circuitos lógicos programables, y con los diferentes medidores compatibles.
Recomendación
  • MatrikonOPC recomienda a los clientes afectados contactar con el equipo de soporte de la compañía, a través del portal de soporte, para obtener la nueva versión del servidor OPC para DNP3.
  • Los investigadores que han identificado la vulnerabilidad también recomiendan bloquear el trafico DNP3 en redes corporativas o de negocio, permitiendo la comunicación unicamente entre los dispositivos necesarios y realizando un filtrado a través un IPS o un cortafuegos con reglas DNP3 especificas.
Más información
Fuente: Inteco